[ATTN NEW RIDERS] Please note that all new forum users have to be approved before posting. This process can take up to 24 hours, and we appreciate your patience.

Launcher.exe has stopped working

ImmortalKhaleesiImmortalKhaleesi
Riders of Icarus Rep: 1,390
Posts: 56
Member
edited February 2, 2017 in Tech Support
Today I wanted to log into the game to collect my daily reward and play with my friends, but every time I clicked Play, it said "Launcher.exe has stopped working".

I checked the forums, Steam discussions and a bunch of Youtube videos... nothing helped. I really have no idea how to fix this, and this is the first time I'm experiencing this issue - it never appeared before.

I play through Steam, and I'm in Europe.

If you have any advice pls tell me! :( :( D: D:
BobbiH59

Comments

  • SamzSamz
    Riders of Icarus Rep: 410
    Posts: 2
    Member
    edited February 2, 2017
    same here... started today. doesn't last 5 minutes. 5 attempts.
    BobbiH59
  • Menegroth_SusejMenegroth_Susej
    Riders of Icarus Rep: 2,560
    Posts: 163
    Member
    edited February 3, 2017
    Try this: close steam completely. Right-click the steam launcher icon and select "Run as Administrator". Run the game and see if it works.

    If it doesn't work, try verifying cache integrity via steam. It'll take a while but, if everything else failed, this should help.

    But if it still doesn't solve the issue, your best bet is to send a ticket to support as detailed as possible so they can help you.
    BobbiH59
  • ImmortalKhaleesiImmortalKhaleesi
    Riders of Icarus Rep: 1,390
    Posts: 56
    Member
    edited February 11, 2017
    How do I verify cache integrity via Steam?
    BobbiH59
  • BobbiH59BobbiH59
    Riders of Icarus Rep: 1,005
    Posts: 37
    Member
    edited February 12, 2017
    it isn't just steam patrons either,,, I'm on nexon launcher,, and it is constant.... have tried many many times all day long... same thing.. freezing up then crashes...
  • LareeshaLareesha
    Riders of Icarus Rep: 410
    Posts: 3
    Member
    edited February 22, 2017
    Same here and didn't have this issue before until maintenance last week. Now it happens everyday constantly.
  • ImmortalKhaleesiImmortalKhaleesi
    Riders of Icarus Rep: 1,390
    Posts: 56
    Member
    edited February 24, 2017
    I uninstalled the game, deleted every trace of it from my PC, uninstalled Steam, and now I installed Steam again and started downloading the full game again... let's pray that works and that my account is still there (I don't wanna start over D:)
  • ImmortalKhaleesiImmortalKhaleesi
    Riders of Icarus Rep: 1,390
    Posts: 56
    Member
    edited February 26, 2017
    I fixed it, finally. I reinstalled the drives for my graphic card, installed Steam from scratch and installed the game again. It worked perfectly and I hope it continues to work that way.